CVE-2026-108822
MEDIUMCVSS 5.3Description
A vulnerability was detected in Kamailio up to 6.0.7/6.1.3. The affected element is the function isup_get_calling_party of the file src/modules/sipt/ss7_parser.c of the component sipt Module. The manipulation of the argument length results in buffer overflow. The attack may be performed from remote. Upgrading to version 6.0.8 and 6.1.4 is sufficient to fix this issue. The patch is identified as 3667bebf8d0bea07ed16218fd921d07db87aeb21. Upgrading the affected component is advised.
Timeline
Published:October 12th, 2026 10:16 AM
Last modified:October 14th, 2026 6:17 PM
CVSS Scoring
CVSS v3: 5.3 (MEDIUM)
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS v2: 5.0
References & Reports
Advisories, patches, and third-party reports
- https://github.com/kamailio/kamailio/
- https://github.com/kamailio/kamailio/commit/3667bebf8d0bea07ed16218fd921d07db87aeb21
- https://github.com/kamailio/kamailio/pull/4905
- https://github.com/kamailio/kamailio/releases/tag/6.0.8
- https://vuldb.com/cve/CVE-2026-108822
- https://vuldb.com/submit/964495
- https://vuldb.com/vuln/416599
- https://vuldb.com/vuln/416599/cti
Source: NIST NVD · Data may lag official sources by up to one minute